GitHub Advisoryadvisory · npm

GHSA-8v67-x8q5-3x3g Cross-Site Scripting in simditor

MEDIUM Published 2019-05-14 Modified 2021-08-04 Official page ↗
Aliases
CVE-2018-19048
Ecosystem
npm
Packages
simditor
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2019-05-14

Affected packages

• npm simditor: < 2.3.22 → fixed in 2.3.22

Description

Versions of `simditor` prior to 2.3.22 are vulnerable to Cross-Site Scripting. The package does not sanitize user input that is rendered with `innerHTML`, allowing attackers to execute arbitrary JavaScript. Recommendation Upgrade to version 2.3.22 or later.

Related

Alias · CVE (1)

  • CVE-2018-19048 Simditor through 2.3.21 allows DOM XSS via an onload attribute within a malformed SVG element. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References