GitHub Advisoryadvisory · Maven

GHSA-8vfm-4388-6rpc Apache is vulnerable to XXE in XSD validation processor

CRITICAL Published 2018-10-16 Modified 2022-11-17 Official page ↗
Aliases
CVE-2018-8027
Ecosystem
Maven
Packages
org.apache.camel:camel-core
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-611
Reviewed
2020-06-16

Affected packages

• Maven org.apache.camel:camel-core: >= 2.20.0, < 2.20.4 → fixed in 2.20.4 • Maven org.apache.camel:camel-core: >= 2.21.0, < 2.21.1 → fixed in 2.21.1

Description

Apache Camel 2.20.0 to 2.20.3 and 2.21.0 Core is vulnerable to XXE in XSD validation processor.

Related

Alias · CVE (1)

  • CVE-2018-8027 Apache Camel 2.20.0 to 2.20.3 and 2.21.0 Core is vulnerable to XXE in XSD validation processor. vulnerability

Weakness · CWE (1)

  • CWE-611 Improper Restriction of XML External Entity Reference weakness

References