GitHub Advisoryadvisory · Go
GHSA-8vrw-m3j9-j27c Denial of Service in jsonparser
HIGH
Official page ↗
- Aliases
- CVE-2020-35381
- Ecosystem
- Go
- Packages
- github.com/buger/jsonparser
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-125
- Reviewed
- 2022-05-25
Affected packages
• Go github.com/buger/jsonparser: < 1.1.1 → fixed in 1.1.1
Description
jsonparser before 1.1.1 allows attackers to cause a denial of service via a GET call.
Related
Alias · CVE (1)
- CVE-2020-35381 jsonparser 1.0.0 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a GET call. vulnerability
Weakness · CWE (1)
- CWE-125 Out-of-bounds Read weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-35381 advisory
- https://github.com/buger/jsonparser/issues/219 web
- https://github.com/buger/jsonparser/pull/221 web
- https://github.com/buger/jsonparser/commit/df3ea76ece10095374fd1c9a22a4fb85a44efc42 web
- https://github.com/buger/jsonparser package
- https://lists.fedoraproject.org/archives/list/[email protected]/message/27EA7OGCELV7QFAGVIHODHWKMKGFVIUZ web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/LJO5N7YTDEUSTKYTNA372CE6VHCZJWUG web
- https://pkg.go.dev/vuln/GO-2021-0057 web