GitHub Advisoryadvisory · Maven

GHSA-8vvh-crqv-jm64 Exposure of Sensitive Information to an Unauthorized Actor in Apache Qpid Broker for Java

HIGH Published 2022-05-17 Modified 2022-07-06 Official page ↗
Aliases
CVE-2016-8741
Ecosystem
Maven
Packages
org.apache.qpid:qpid-broker
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-200
Reviewed
2022-07-06

Affected packages

• Maven org.apache.qpid:qpid-broker: >= 6.0.0, < 6.0.6 → fixed in 6.0.6 • Maven org.apache.qpid:qpid-broker: >= 6.1.0, < 6.1.1 → fixed in 6.1.1

Description

The Apache Qpid Broker for Java can be configured to use different so called AuthenticationProviders to handle user authentication. Among the choices are the SCRAM-SHA-1 and SCRAM-SHA-256 AuthenticationProvider types. It was discovered that these AuthenticationProviders in Apache Qpid Broker for Java 6.0.x before 6.0.6 and 6.1.x before 6.1.1 prematurely terminate the SCRAM SASL negotiation if the provided user name does not exist thus allowing remote attacker to determine the existence of user accounts. The Vulnerability does not apply to AuthenticationProviders other than SCRAM-SHA-1 and SCRAM-SHA-256.

Related

Alias · CVE (1)

  • CVE-2016-8741 The Apache Qpid Broker for Java can be configured to use different so called AuthenticationProviders to handle user authentication. vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References