GitHub Advisoryadvisory · Packagist

GHSA-8w3p-qh3x-6gjr TYPO3 CMS vulnerable to Sensitive Information Disclosure via YAML Placeholder Expressions in Site Configuration

MEDIUM Published 2022-12-13 Modified 2024-10-29 Official page ↗
Aliases
CVE-2022-23504
Ecosystem
Packagist
Packages
typo3/cms-core, typo3/cms
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:L/A:L
Weaknesses
CWE-200, CWE-917
Reviewed
2022-12-13

Affected packages

• Packagist typo3/cms-core: >= 9.0.0, < 9.5.38 → fixed in 9.5.38 • Packagist typo3/cms-core: >= 10.0.0, < 10.4.33 → fixed in 10.4.33 • Packagist typo3/cms-core: >= 11.0.0, < 11.5.20 → fixed in 11.5.20 • Packagist typo3/cms-core: >= 12.0.0, < 12.1.1 → fixed in 12.1.1 • Packagist typo3/cms: >= 10.0.0, < 10.4.33 → fixed in 10.4.33 • Packagist typo3/cms: >= 11.0.0, < 11.5.20 → fixed in 11.5.20 • Packagist typo3/cms: >= 12.0.0, < 12.1.1 → fixed in 12.1.1

Description

> ### CVSS: `CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:L/A:L/E:F/RL:O/RC:C` (5.3) Problem Due to the lack of handling user-submitted YAML placeholder expressions in the site configuration backend module, attackers could expose sensitive internal information, such as system configuration or HTTP request messages of other website visitors. A valid backend user account having administrator privileges is needed to exploit this vulnerability. Solution Update to TYPO3 versions 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1 that fix the problem described above. Credits Thanks to TYPO3 core & security team member Oliver Hader who reported and fixed the issue. References • TYPO3-CORE-SA-2022-016

Related

Alias · CVE (1)

  • CVE-2022-23504 TYPO3 is an open source PHP based web content management system. vulnerability

Weakness · CWE (2)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
  • CWE-917 Improper Neutralization of Special Elements used in an Expression Language Statement weakness

References