GitHub Advisoryadvisory · PyPI

GHSA-8w48-m6hx-rjw2 Zope Command Execution Vulnerability

HIGH Published 2022-05-17 Modified 2024-11-22 Official page ↗
Aliases
CVE-2011-3587
Ecosystem
PyPI
Packages
zope2
Severity
High
Reviewed
2024-01-15

Affected packages

• PyPI zope2: >= 2.12.0, < 2.12.20 → fixed in 2.12.20 • PyPI zope2: >= 2.13.0, < 2.13.10 → fixed in 2.13.10

Description

Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through 4.0.9, 4.1, and 4.2 through 4.2a2, allows remote attackers to execute arbitrary commands via vectors related to the `p_` class in `OFS/misc_.py` and the use of Python modules.

Related

Alias · CVE (1)

  • CVE-2011-3587 Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through 4.0.9, 4.1, and 4.2 through 4.2a2, allows remote… vulnerability

References