GitHub Advisoryadvisory · PyPI

GHSA-8w5g-3wcv-9g2j Tensorflow vulnerable to Out-of-Bounds Read

MEDIUM Published 2022-11-22 Modified 2022-11-22 Official page ↗
Aliases
CVE-2022-41880
Ecosystem
PyPI
Packages
tensorflow, tensorflow-cpu, tensorflow-gpu
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:H
Weaknesses
CWE-125
Reviewed
2022-11-22

Affected packages

• PyPI tensorflow: >= 2.10.0, < 2.10.1 → fixed in 2.10.1 • PyPI tensorflow-cpu: >= 2.10.0, < 2.10.1 → fixed in 2.10.1 • PyPI tensorflow-gpu: >= 2.10.0, < 2.10.1 → fixed in 2.10.1 • PyPI tensorflow: < 2.8.4 → fixed in 2.8.4 • PyPI tensorflow-cpu: < 2.8.4 → fixed in 2.8.4 • PyPI tensorflow-gpu: < 2.8.4 → fixed in 2.8.4 • PyPI tensorflow: >= 2.9.0, < 2.9.3 → fixed in 2.9.3 • PyPI tensorflow-cpu: >= 2.9.0, < 2.9.3 → fixed in 2.9.3 • PyPI tensorflow-gpu: >= 2.9.0, < 2.9.3 → fixed in 2.9.3

Description

Impact When the `BaseCandidateSamplerOp` function receives a value in `true_classes` larger than `range_max`, a heap oob vuln occurs. ```python tf.raw_ops.ThreadUnsafeUnigramCandidateSampler( true_classes=[[0x100000,1]], num_true = 2, num_sampled = 2, unique = False, range_max = 2, seed = 2, seed2 = 2) ``` Patches We have patched the issue in GitHub commit b389f5c944cadfdfe599b3f1e4026e036f30d2d4. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported by Yu Tian of Qihoo 360 AIVul Team.

Related

Alias · CVE (1)

  • CVE-2022-41880 TensorFlow is an open source platform for machine learning. vulnerability

Weakness · CWE (1)

  • CWE-125 Out-of-bounds Read weakness

References