GitHub Advisoryadvisory · npm
GHSA-8w65-xjc5-9w79 Cross-Site Scripting in node-red
MEDIUM
Official page ↗
- Aliases
- CVE-2019-15607
- Ecosystem
- npm
- Packages
- node-red
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-01-29
Affected packages
• npm node-red: < 0.20.8 → fixed in 0.20.8
Description
Versions of `node-red` prior to 0.20.8are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize the `name` field in new Flows, allowing attackers to execute arbitrary JavaScript in the victim's browser.
Recommendation
Upgrade to version 0.18.6 or later.
Related
Alias · CVE (1)
- CVE-2019-15607 A stored XSS vulnerability is present within node-red (version: <= 0.20.7) npm package, which is a visual tool for wiring the Internet of… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness