GitHub Advisoryadvisory · npm
GHSA-8wgc-jjvv-cv6v Improper Authorization in loopback
HIGH
Official page ↗
- Ecosystem
- npm
- Packages
- loopback
- Severity
- High
- Weaknesses
- CWE-285
- Reviewed
- 2020-08-31
Affected packages
• npm loopback: < 2.40.0 → fixed in 2.40.0
• npm loopback: >= 3.0.0, < 3.22.0 → fixed in 3.22.0
Description
Vulnerable versions of `loopback` may allow attackers to create Authentication Tokens on behalf of other users due to Improper Authorization. If the AccessToken model is publicly exposed, an attacker can create Authorization Tokens for any user as long as they know the target's `userId`. This will allow the attacker to access the user's data and their privileges.
Recommendation
For loopback 2.x, upgrade to version 2.40.0 or later
For loopback 3.x, upgrade to version 3.22.0 or later
Related
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness