GitHub Advisoryadvisory · Packagist
GHSA-8wj3-cpmr-8whp Cockpit Content Platform vulnerable to 2FA bypass
HIGH
Official page ↗
- Aliases
- CVE-2022-2818
- Ecosystem
- Packagist
- Packages
- cockpit-hq/cockpit
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-212, CWE-287, CWE-305
- Reviewed
- 2022-08-18
Affected packages
• Packagist cockpit-hq/cockpit: < 2.2.2 → fixed in 2.2.2
Description
Cockpit Content Platform through version 2.2.1 is vulnerable to a two-factor authentication (2FA) bypass. The 2FA secret is disclosed in a JWT token after user logs into their account, allowing an attacker to bypass the 2FA code. A patch is available on the `develop` branch and is expected to be part of version 2.2.2.
Related
Alias · CVE (1)
- CVE-2022-2818 Improper Removal of Sensitive Information Before Storage or Transfer in GitHub repository cockpit-hq/cockpit prior to 2.2.2. vulnerability