GitHub Advisoryadvisory · PyPI

GHSA-8wwm-6264-x792 Core dump when loading TFLite models with quantization in TensorFlow

MEDIUM Published 2022-05-24 Modified 2022-06-06 Official page ↗
Aliases
CVE-2022-29212
Ecosystem
PyPI
Packages
tensorflow, tensorflow-cpu, tensorflow-gpu
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2022-05-24

Affected packages

• PyPI tensorflow: < 2.6.4 → fixed in 2.6.4 • PyPI tensorflow: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-cpu: < 2.6.4 → fixed in 2.6.4 • PyPI tensorflow-cpu: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-gpu: < 2.6.4 → fixed in 2.6.4 • PyPI tensorflow-gpu: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1

Description

Impact Certain TFLite models that were created using TFLite model converter would crash when loaded in the TFLite interpreter. The culprit is that during quantization the scale of values could be greater than 1 but code was always assuming sub-unit scaling. Thus, since code was calling `QuantizeMultiplierSmallerThanOneExp`, the `TFLITE_CHECK_LT` assertion would trigger and abort the process. Patches We have patched the issue in GitHub commit a989426ee1346693cc015792f11d715f6944f2b8. The fix will be included in TensorFlow 2.9.0. We will also cherrypick this commit on TensorFlow 2.8.1, TensorFlow 2.7.2, and TensorFlow 2.6.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported externally via a GitHub issue.

Related

Alias · CVE (1)

  • CVE-2022-29212 TensorFlow is an open source platform for machine learning. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References