GitHub Advisoryadvisory · Packagist

GHSA-8xv7-g2q3-fqgc Mautic allows Improper Authorization in Reporting API

HIGH Published 2025-02-26 Modified 2025-10-16 Official page ↗
Aliases
CVE-2024-47053
Ecosystem
Packagist
Packages
mautic/core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Weaknesses
CWE-285, CWE-863
Reviewed
2025-02-26

Affected packages

• Packagist mautic/core: >= 1.0.1, < 5.2.3 → fixed in 5.2.3

Description

Summary This advisory addresses an authorization vulnerability in Mautic's HTTP Basic Authentication implementation. This flaw could allow unauthorized access to sensitive report data. • Improper Authorization: An authorization flaw exists in Mautic's API Authorization implementation. Any authenticated user, regardless of assigned roles or permissions, can access all reports and their associated data via the API. This bypasses the intended access controls governed by the "Reporting Permissions > View Own" and "Reporting Permissions > View Others" permissions, which should restrict access to non-System Reports. Mitigation Please update to Mautic 5.2.3 or later Workarounds Disable the API in Mautic. See documentation. References https://cwe.mitre.org/data/definitions/285.html https://docs.mautic.org/en/5.2/configuration/settings.html#api-settings If you have any questions or comments about this advisory: Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2024-47053 This advisory addresses an authorization vulnerability in Mautic's HTTP Basic Authentication implementation. vulnerability

Weakness · CWE (2)

  • CWE-285 Improper Authorization weakness
  • CWE-863 Incorrect Authorization weakness

References