GitHub Advisoryadvisory · PyPI

GHSA-923p-fr2c-g5m2 Exposure of Sensitive Information to an Unauthorized Actor in Ansible

LOW Published 2021-04-07 Modified 2024-09-06 Official page ↗
Aliases
CVE-2020-1739
Ecosystem
PyPI
Packages
ansible
Severity
Low
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
Weaknesses
CWE-200
Reviewed
2021-04-05

Affected packages

• PyPI ansible: < 2.7.17 → fixed in 2.7.17 • PyPI ansible: >= 2.8.0a1, < 2.8.11 → fixed in 2.8.11 • PyPI ansible: >= 2.9.0a1, < 2.9.7 → fixed in 2.9.7

Description

A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the same node. An attacker could take advantage by reading the cmdline file from that particular PID on the procfs.

Related

Alias · CVE (1)

  • CVE-2020-1739 A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References