GitHub Advisoryadvisory · Packagist
GHSA-923w-2xv2-7pr8 SimpleSAMLphp Improper Verification of Cryptographic Signature
HIGH
Official page ↗
- Aliases
- CVE-2018-7644
- Ecosystem
- Packagist
- Packages
- simplesamlphp/saml2
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-347
- Reviewed
- 2024-04-25
Affected packages
• Packagist simplesamlphp/saml2: < 1.10.5 → fixed in 1.10.5
• Packagist simplesamlphp/saml2: >= 2.0, < 2.3.7 → fixed in 2.3.7
• Packagist simplesamlphp/saml2: >= 3.0, < 3.1.3 → fixed in 3.1.3
Description
The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Identity Provider that would pass as cryptographically valid, thereby allowing them to impersonate a user from that Identity Provider, aka a key confusion issue.
Related
Alias · CVE (1)
- CVE-2018-7644 The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions,… vulnerability
Weakness · CWE (1)
- CWE-347 Improper Verification of Cryptographic Signature weakness