GitHub Advisoryadvisory · Maven

GHSA-9284-j4c9-779q Improper Input Validation in Apache Jackrabbit

MEDIUM Published 2022-05-14 Modified 2024-04-12 Official page ↗
Aliases
CVE-2015-1833
Ecosystem
Maven
Packages
org.apache.jackrabbit:jackrabbit-core
Severity
Moderate
Weaknesses
CWE-20
Reviewed
2022-07-06

Affected packages

• Maven org.apache.jackrabbit:jackrabbit-core: < 2.0.6 → fixed in 2.0.6 • Maven org.apache.jackrabbit:jackrabbit-core: >= 2.2.0, < 2.2.14 → fixed in 2.2.14 • Maven org.apache.jackrabbit:jackrabbit-core: >= 2.4.0, < 2.4.6 → fixed in 2.4.6 • Maven org.apache.jackrabbit:jackrabbit-core: >= 2.6.0, < 2.6.6 → fixed in 2.6.6 • Maven org.apache.jackrabbit:jackrabbit-core: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • Maven org.apache.jackrabbit:jackrabbit-core: >= 2.10.0, < 2.10.1 → fixed in 2.10.1

Description

XML external entity (XXE) vulnerability in Apache Jackrabbit before 2.0.6, 2.2.x before 2.2.14, 2.4.x before 2.4.6, 2.6.x before 2.6.6, 2.8.x before 2.8.1, and 2.10.x before 2.10.1 allows remote attackers to read arbitrary files and send requests to intranet servers via a crafted WebDAV request.

Related

Alias · CVE (1)

  • CVE-2015-1833 XML external entity (XXE) vulnerability in Apache Jackrabbit before 2.0.6, 2.2.x before 2.2.14, 2.4.x before 2.4.6, 2.6.x before 2.6.6,… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References