GitHub Advisoryadvisory · npm
GHSA-92gp-jfgx-9qpv Hyperterse: Raw exposure of database statements in MCP search tool
MEDIUM
Official page ↗
- Aliases
- CVE-2026-31841
- Ecosystem
- npm
- Packages
- hyperterse
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-433
- Reviewed
- 2026-03-12
Affected packages
• npm hyperterse: >= 2.0.0, < 2.2.0 → fixed in 2.2.0
Description
Hyperterse allows users to specify database queries for tools to execute under the hood. As of v2.0.0, there are only two tools exposed - `search` and `execute`.
The `search` tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly.
This issue has been fixed as of v2.2.0 and relevant tests to catch these have been added.
Related
Alias · CVE (1)
- CVE-2026-31841 Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. vulnerability
Weakness · CWE (1)
- CWE-433 Unparsed Raw Web Content Delivery weakness