GitHub Advisoryadvisory · PyPI
GHSA-92j5-3459-qgp4 LangChain vulnerable to arbitrary code execution
CRITICAL
Official page ↗
- Aliases
- CVE-2023-38896
- Ecosystem
- PyPI
- Packages
- langchain
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74, CWE-94
- Reviewed
- 2023-08-15
Affected packages
• PyPI langchain: < 0.0.236 → fixed in 0.0.236
Description
An issue in Harrison Chase langchain before version 0.0.236 allows a remote attacker to execute arbitrary code via the `from_math_prompt` and `from_colored_object_prompt` functions.
Related
Alias · CVE (1)
- CVE-2023-38896 An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to execute arbitrary code via the from_math_prompt and… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-38896 advisory
- https://github.com/hwchase17/langchain/issues/5872 web
- https://github.com/hwchase17/langchain/pull/6003 web
- https://github.com/langchain-ai/langchain/commit/8ba9835b925473655914f63822775679e03ea137 web
- https://github.com/langchain-ai/langchain/commit/e294ba475a355feb95003ed8f1a2b99942509a9e web
- https://github.com/langchain-ai/langchain package
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-146.yaml web
- https://twitter.com/llm_sec/status/1668711587287375876 web