GitHub Advisoryadvisory · PyPI
GHSA-92mr-v722-f48m Improper Input Validation in Jupyter Notebook
CRITICAL
Official page ↗
- Aliases
- CVE-2015-7337
- Ecosystem
- PyPI
- Packages
- notebook, ipython
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-07-06
Affected packages
• PyPI notebook: >= 4.0.0, < 4.0.5 → fixed in 4.0.5
• PyPI ipython: < 3.2.2 → fixed in 3.2.2
Description
The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/, related to MIME types.
Related
Alias · CVE (1)
- CVE-2015-7337 The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-7337 advisory
- https://github.com/ipython/ipython/commit/0a8096adf165e2465550bd5893d7e352544e5967 web
- https://github.com/jupyter/notebook/commit/9e63dd89b603dfbe3a7e774d8a962ee0fa30c0b5 web
- https://bugzilla.redhat.com/show_bug.cgi?id=1264067 web
- https://github.com/advisories/GHSA-92mr-v722-f48m advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/ipython/PYSEC-2015-25.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/notebook/PYSEC-2015-27.yaml web
- https://security.gentoo.org/glsa/201512-02 web
- http://lists.fedoraproject.org/pipermail/package-announce/2015-September/167670.html web
- http://seclists.org/oss-sec/2015/q3/558 web
- http://seclists.org/oss-sec/2015/q3/634 web