GitHub Advisoryadvisory · Packagist
GHSA-92q5-2h76-vgmj moodle Improper Access Control
MEDIUM
Official page ↗
- Aliases
- CVE-2019-10188
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-284
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: < 3.5.7 → fixed in 3.5.7
• Packagist moodle/moodle: >= 3.6.0, < 3.6.5 → fixed in 3.6.5
• Packagist moodle/moodle: >= 3.7.0, < 3.7.1 → fixed in 3.7.1
Description
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Teachers in a quiz group could modify group overrides for other groups in the same quiz.
Related
Alias · CVE (1)
- CVE-2019-10188 A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness