GitHub Advisoryadvisory · Maven
GHSA-92rv-mvmj-47qh Jenkins GitHub Pull Request Builder Plugin credential capture vulnerability
LOW
Official page ↗
- Aliases
- CVE-2018-1000186
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:ghprb
- Severity
- Low
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2022-12-12
Affected packages
• Maven org.jenkins-ci.plugins:ghprb: < 1.42.0 → fixed in 1.42.0
Description
A exposure of sensitive information vulnerability exists in Jenkins GitHub Pull Request Builder Plugin 1.41.0 and older in GhprbGitHubAuth.java that allows attackers with Overall/Read access to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, these form validation methods did not require POST requests, resulting in a CSRF vulnerability. As of version 1.42.0, these form validation methods require POST requests and Overall/Administer permissions.
Related
Alias · CVE (1)
- CVE-2018-1000186 A exposure of sensitive information vulnerability exists in Jenkins GitHub Pull Request Builder Plugin 1.41.0 and older in… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000186 advisory
- https://github.com/jenkinsci/ghprb-plugin/commit/e78ee24f7056b8507992ef17a9bb74a1a31d8c11 web
- https://github.com/jenkinsci/ghprb-plugin package
- https://jenkins.io/security/advisory/2018-06-04/#SECURITY-805 web
- https://mvnrepository.com/artifact/org.jenkins-ci.plugins/ghprb web