GitHub Advisoryadvisory · RubyGems

GHSA-92v7-pq4h-58j5 facter, hiera, mcollective-client, and puppet affected by untrusted search path vulnerability

MEDIUM Published 2017-10-24 Modified 2023-06-07 Official page ↗
Aliases
CVE-2014-3248
Ecosystem
RubyGems
Packages
facter, hiera, puppet, mcollective-client
Severity
Moderate
Reviewed
2020-06-16

Affected packages

• RubyGems facter: < 1.7.6 → fixed in 1.7.6 • RubyGems facter: >= 2.0.0, < 2.0.2 → fixed in 2.0.2 • RubyGems hiera: < 1.3.4 → fixed in 1.3.4 • RubyGems puppet: < 2.7.26 → fixed in 2.7.26 • RubyGems puppet: >= 3.0.0, < 3.6.2 → fixed in 3.6.2 • RubyGems mcollective-client: < 2.5.2 → fixed in 2.5.2

Description

Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) `rubygems/defaults/operating_system.rb`, (2) `Win32API.rb`, (3) `Win32API.so`, (4) `safe_yaml.rb`, (5) `safe_yaml/deep.rb`, or (6) `safe_yaml/deep.so`; or (7) `operatingsystem.rb`, (8) `operatingsystem.so`, (9) `osfamily.rb`, or (10) `osfamily.so` in `puppet/confine`.

Related

Alias · CVE (1)

  • CVE-2014-3248 Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x… vulnerability

References