GitHub Advisoryadvisory · Maven

GHSA-932v-x9x2-vq29 Hive Metastore Server is vulnerable to SQL Injection

HIGH Published 2025-11-26 Modified 2025-12-01 Official page ↗
Aliases
CVE-2025-62728
Ecosystem
Maven
Packages
org.apache.hive:hive-common, org.apache.hive:hive-metastore
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-89
Reviewed
2025-12-01

Affected packages

• Maven org.apache.hive:hive-common: >= 4.1.0, < 4.2.0 → fixed in 4.2.0 • Maven org.apache.hive:hive-metastore: >= 4.1.0, < 4.2.0 → fixed in 4.2.0

Description

SQL injection vulnerability in Hive Metastore Server (HMS) when processing delete column statistics requests via the Thrift APIs. The vulnerability is only exploitable by trusted/authorized users/applications that are allowed to call directly the Thrift APIs. In most real-world deployments, HMS is accessible to only a handful of applications (e.g., Hiveserver2) thus the vulnerability is not exploitable. Moreover, the vulnerable code cannot be reached when metastore.try.direct.sql property is set to false. This issue affects Apache Hive: from 4.1.0 before 4.2.0. Users are recommended to upgrade to version 4.2.0, which fixes the issue. Users who cannot upgrade directly are encouraged to set metastore.try.direct.sql property to false if the HMS Thrift APIs are exposed to general public.

Related

Alias · CVE (1)

  • CVE-2025-62728 SQL injection vulnerability in Hive Metastore Server (HMS) when processing delete column statistics requests via the Thrift APIs. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References