GitHub Advisoryadvisory · Packagist
GHSA-93pj-4p65-qmr9 Insufficient user authorization in Moodle
MEDIUM
Official page ↗
- Aliases
- CVE-2022-0334
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-668, CWE-863
- Reviewed
- 2022-01-26
Affected packages
• Packagist moodle/moodle: >= 3.11, < 3.11.5 → fixed in 3.11.5
• Packagist moodle/moodle: >= 3.10, < 3.10.8 → fixed in 3.10.8
• Packagist moodle/moodle: < 3.9.11 → fixed in 3.9.11
Description
A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. Insufficient capability checks could lead to users accessing their grade report for courses where they did not have the required gradereport/user:view capability.
Related
Alias · CVE (1)
- CVE-2022-0334 A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-0334 advisory
- https://github.com/moodle/moodle/commit/1964d68f8500ea3c7b776fa8a2af6266ed109f84 web
- https://github.com/moodle/moodle/commit/6d18f136ae88ec97e351a723df570816a959ec68 web
- https://bugzilla.redhat.com/show_bug.cgi?id=2043664 web
- https://moodle.org/mod/forum/discuss.php?d=431102 web