GitHub Advisoryadvisory · PyPI, Maven

GHSA-9437-39hj-3c93 Apache Spark History Server allows stored cross-site scripting through unescaped application names

MEDIUM Published 2026-09-02 Modified 2026-10-05 Official page ↗
Aliases
CVE-2026-32773
Ecosystem
PyPI, Maven
Packages
pyspark, org.apache.spark:spark-core_2.12, org.apache.spark:spark-core_2.13
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-80
Reviewed
2026-10-05

Affected packages

• PyPI pyspark: >= 3.0.0, < 3.5.8 → fixed in 3.5.8 • Maven org.apache.spark:spark-core_2.12: >= 3.0.0, < 3.5.8 → fixed in 3.5.8 • Maven org.apache.spark:spark-core_2.13: >= 3.0.0, < 3.5.8 → fixed in 3.5.8

Description

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

Related

Alias · CVE (1)

  • CVE-2026-32773 There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary… vulnerability

Weakness · CWE (1)

  • CWE-80 Improper Neutralization of Script-Related HTML Tags in a Web Page weakness

References