GitHub Advisoryadvisory · RubyGems
GHSA-94hm-8q65-rmxm OmniAuth-SAML authentication bypass via incorrect XML canonicalization and DOM traversal
HIGH
Official page ↗
- Aliases
- CVE-2017-11430
- Ecosystem
- RubyGems
- Packages
- omniauth-saml
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-287
- Reviewed
- 2020-06-16
Affected packages
• RubyGems omniauth-saml: < 1.10.0 → fixed in 1.10.0
Description
OmniAuth OmniAuth-SAML 1.9.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.
Related
Alias · CVE (1)
- CVE-2017-11430 OmniAuth OmnitAuth-SAML 1.9.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way… vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-11430 advisory
- https://duo.com/blog/duo-finds-saml-vulnerabilities-affecting-multiple-implementations web
- https://github.com/omniauth/omniauth-saml package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-saml/CVE-2017-11430.yml web
- https://www.kb.cert.org/vuls/id/475445 web