GitHub Advisoryadvisory · Packagist

GHSA-954p-ff72-327w Adobe Commerce Path Traversal

HIGH Published 2025-02-11 Modified 2025-03-17 Official page ↗
Aliases
CVE-2025-24406
Ecosystem
Packagist
Packages
magento/community-edition, magento/project-community-edition
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-22
Reviewed
2025-02-28

Affected packages

• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p4 → fixed in 2.4.7-p4 • Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p9 → fixed in 2.4.6-p9 • Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p11 → fixed in 2.4.5-p11 • Packagist magento/community-edition: < 2.4.4-p12 → fixed in 2.4.4-p12 • Packagist magento/community-edition: 2.4.7 (no fix yet) • Packagist magento/community-edition: 2.4.6 (no fix yet) • Packagist magento/community-edition: 2.4.5 (no fix yet) • Packagist magento/community-edition: 2.4.4 (no fix yet) • Packagist magento/community-edition: 2.4.8-beta1 (no fix yet) • Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)

Description

Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could lead to a security feature bypass. An unauthenticated attacker could exploit this vulnerability to modify files that are stored outside the restricted directory. Exploitation of this issue does not require user interaction.

Related

Alias · CVE (1)

  • CVE-2025-24406 Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Improper Limitation of a… vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References