GitHub Advisoryadvisory · npm
GHSA-955m-rr6m-2f9v @sap/cds-mtx: Credential disclosure in multitenant applications using SAP Cloud Application Programming Model (CAP)
CRITICAL
Official page ↗
- Aliases
- CVE-2026-76969
- Ecosystem
- npm
- Packages
- @sap/cds-mtxs
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H
- Weaknesses
- CWE-522
- Reviewed
- 2026-09-17
Affected packages
• npm @sap/cds-mtxs: >= 4.0.1, < 4.0.3 → fixed in 4.0.3
• npm @sap/cds-mtxs: >= 3.0.1, < 3.9.7 → fixed in 3.9.7
• npm @sap/cds-mtxs: >= 2.0.2, < 2.7.7 → fixed in 2.7.7
• npm @sap/cds-mtxs: < 1.18.4 → fixed in 1.18.4
Description
@sap/cds-mtxs NPM library does not perform sufficient checks on certain functionality used in multitenant CAP applications with extensibility enabled. An unauthenticated attacker could send specially crafted requests to obtain sensitive credentials and abuse them to replace or delete tenant data. Successful exploitation can result in a high impact on availability and integrity of the application. There may also be partial impact to the confidentiality of business data.
Related
Alias · CVE (1)
- CVE-2026-76969 @sap/cds-mtxs NPM library does not perform sufficient checks on certain functionality used in multitenant CAP applications with… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness