GitHub Advisoryadvisory · PyPI

GHSA-95mg-jgfx-54v9 Apache Superset uncontrolled resource consumption

MEDIUM Published 2023-12-19 Modified 2025-02-13 Official page ↗
Aliases
CVE-2023-46104
Ecosystem
PyPI
Packages
apache-superset
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2023-12-19

Affected packages

• PyPI apache-superset: < 2.1.2 → fixed in 2.1.2 • PyPI apache-superset: >= 3.0.0, < 3.1.0rc1 → fixed in 3.1.0rc1

Description

Uncontrolled resource consumption can be triggered by authenticated attacker that uploads a malicious ZIP to import database, dashboards or datasets.   This vulnerability exists in Apache Superset versions up to and including 2.1.2 and versions 3.0.0, 3.0.1.

Related

Alias · CVE (1)

  • CVE-2023-46104 Uncontrolled resource consumption can be triggered by authenticated attacker that uploads a malicious ZIP to import database, dashboards or… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References