GitHub Advisoryadvisory · PyPI

GHSA-95rw-fx8r-36v6 Cross-site Scripting in Django

MEDIUM Published 2022-02-04 Modified 2024-09-20 Official page ↗
Aliases
CVE-2022-22818
Ecosystem
PyPI
Packages
Django
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-02-04

Affected packages

• PyPI Django: >= 2.2, < 2.2.27 → fixed in 2.2.27 • PyPI Django: >= 3.2, < 3.2.12 → fixed in 3.2.12 • PyPI Django: >= 4.0, < 4.0.2 → fixed in 4.0.2

Description

The `{% debug %}` template tag in Django 2.2 before 2.2.27, 3.2 before 3.2.12, and 4.0 before 4.0.2 does not properly encode the current context. This may lead to XSS.

Related

Alias · CVE (1)

  • CVE-2022-22818 The {% debug %} template tag in Django 2.2 before 2.2.27, 3.2 before 3.2.12, and 4.0 before 4.0.2 does not properly encode the current… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References