GitHub Advisoryadvisory · RubyGems
GHSA-95xq-v4m2-fq3r GitLab Grit Gem for Ruby contains a flaw allowing arbitrary commands to be executed
MEDIUM
Official page ↗
- Aliases
- CVE-2013-4489
- Ecosystem
- RubyGems
- Packages
- gitlab-grit
- Severity
- Moderate
- Weaknesses
- CWE-20
- Reviewed
- 2023-06-09
Affected packages
• RubyGems gitlab-grit: < 2.6.1 → fixed in 2.6.1
Description
The Grit gem for Ruby, as used in GitLab 5.2 before 5.4.1 and 6.x before 6.2.3, allows remote authenticated users to execute arbitrary commands, as demonstrated by the search box for the GitLab code search feature.
GitLab Grit Gem for Ruby contains a flaw in the app/contexts/search_context.rb script. The issue is triggered when input passed via the code search box is not properly sanitized, which allows strings to be evaluated by the shell. This may allow a remote attacker to execute arbitrary commands.
Related
Alias · CVE (1)
- CVE-2013-4489 The Grit gem for Ruby, as used in GitLab 5.2 before 5.4.1 and 6.x before 6.2.3, allows remote authenticated users to execute arbitrary… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2013-4489 advisory
- https://github.com/gitlabhq/grit/commit/40f33a4f4f5604c2a531a1d86901fd81ac4402c4 web
- https://github.com/gitlabhq/grit package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/gitlab-grit/CVE-2013-4489.yml web
- https://gitlab.com/gitlab-org/gitlab-grit/-/blob/v2.6.1/History.txt?ref_type=tags#L2 web
- https://www.gitlab.com/2013/11/04/gitlab-ce-6-2-and-5-4-security-release web