GitHub Advisoryadvisory · Packagist

GHSA-966m-m549-2878 Moodle is vulnerable to unauthorized new accounts creation

MEDIUM Published 2022-05-13 Modified 2024-02-07 Official page ↗
Aliases
CVE-2010-1616
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-284
Reviewed
2024-02-07

Affected packages

• Packagist moodle/moodle: >= 1.8.0, < 1.8.12 → fixed in 1.8.12 • Packagist moodle/moodle: >= 1.9.0, < 1.9.8 → fixed in 1.9.8

Description

Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they do not have the moodle/user:create capability.

Related

Alias · CVE (1)

  • CVE-2010-1616 Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References