GitHub Advisoryadvisory · Packagist

GHSA-969v-mwp3-4mr3 Magento 2 Community Edition RCE Vulnerability

HIGH Published 2022-05-24 Modified 2024-02-12 Official page ↗
Aliases
CVE-2019-7932
Ecosystem
Packagist
Packages
magento/community-edition
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2023-07-17

Affected packages

• Packagist magento/community-edition: >= 2.1, < 2.1.18 → fixed in 2.1.18 • Packagist magento/community-edition: >= 2.2, < 2.2.9 → fixed in 2.2.9 • Packagist magento/community-edition: >= 2.3, < 2.3.2 → fixed in 2.3.2

Description

A remote code execution vulnerability exists in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with admin privileges to create sitemaps can execute arbitrary PHP code by creating a malicious sitemap file.

Related

Alias · CVE (1)

  • CVE-2019-7932 A remote code execution vulnerability exists in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References