GitHub Advisoryadvisory · PyPI
GHSA-96hw-v598-jvgh Cobbler vulnerable to arbitrary code execution
CRITICAL
Official page ↗
- Aliases
- CVE-2017-1000469
- Ecosystem
- PyPI
- Packages
- cobbler
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2023-07-26
Affected packages
• PyPI cobbler: < 3.0.0 → fixed in 3.0.0
Description
Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the "add repo" component resulting in arbitrary code execution as root user.
Related
Alias · CVE (1)
- CVE-2017-1000469 Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the "add repo" component resulting in arbitrary code… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000469 advisory
- https://github.com/cobbler/cobbler/issues/1845 web
- https://github.com/cobbler/cobbler/commit/4b20397425a5d42a2d8927233654f4d7435bd4c2 web
- https://github.com/cobbler/cobbler package
- https://github.com/pypa/advisory-database/tree/main/vulns/cobbler/PYSEC-2026-314.yaml web
- https://pypi.org/project/cobbler web