GitHub Advisoryadvisory · PyPI
GHSA-9772-cwx9-r4cj simplejson before 2.6.1 vulnerable to array index error
MEDIUM
Official page ↗
- Aliases
- CVE-2014-4616
- Ecosystem
- PyPI
- Packages
- simplejson
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-129
- Reviewed
- 2022-07-27
Affected packages
• PyPI simplejson: < 2.6.1 → fixed in 2.6.1
Description
Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the raw_decode function.
Related
Alias · CVE (1)
- CVE-2014-4616 Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows… vulnerability
Weakness · CWE (1)
- CWE-129 Improper Validation of Array Index weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-4616 advisory
- https://hackerone.com/reports/12297 web
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=752395 web
- https://bugzilla.redhat.com/show_bug.cgi?id=1112285 web
- https://github.com/simplejson/simplejson package
- https://security.gentoo.org/glsa/201503-10 web
- http://bugs.python.org/issue21529 web
- http://lists.opensuse.org/opensuse-updates/2014-07/msg00015.html web
- http://openwall.com/lists/oss-security/2014/06/24/7 web
- http://rhn.redhat.com/errata/RHSA-2015-1064.html web
- http://www.securityfocus.com/bid/68119 web