GitHub Advisoryadvisory · Packagist
GHSA-9778-v769-qvjf code16 Sharp vulnerable to Cross Site Scripting (XSS)
MEDIUM
Official page ↗
- Aliases
- CVE-2025-61457
- Ecosystem
- Packagist
- Packages
- code16/sharp
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-10-21
Affected packages
• Packagist code16/sharp: < 9.7.0 → fixed in 9.7.0
Description
code16 Sharp v9.6.6 is vulnerable to Cross Site Scripting (XSS) src/Form/Fields/SharpFormUploadField.php.
Related
Alias · CVE (1)
- CVE-2025-61457 code16 Sharp v9.6.6 is vulnerable to Cross Site Scripting (XSS) src/Form/Fields/SharpFormUploadField.php. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-61457 advisory
- https://github.com/code16/sharp/issues/611 web
- https://github.com/code16/sharp/commit/bf7fedf2086d86aac16194733a6385564e5cf124 web
- https://github.com/chimmeee/vulnerability-research/blob/main/CVE-2025-61457 web
- https://github.com/code16/sharp package
- https://github.com/code16/sharp/blob/6d106b05aa07c6b46f5de28f909b732e1bbcdc47/src/Form/Fields/SharpFormUploadField.php#L97 web
- https://github.com/code16/sharp/releases/tag/v9.7.0 web