GitHub Advisoryadvisory · npm
GHSA-97m3-w2cp-4xx6 Embedded Malicious Code in node-ipc
CRITICAL
Official page ↗
- Aliases
- CVE-2022-23812
- Ecosystem
- npm
- Packages
- node-ipc
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-506, CWE-94
- Reviewed
- 2022-03-16
Affected packages
• npm node-ipc: >= 10.1.1, < 10.1.3 → fixed in 10.1.3
Description
The package node-ipc versions 10.1.1 and 10.1.2 are vulnerable to embedded malicious code that was introduced by the maintainer. The malicious code was intended to overwrite arbitrary files dependent upon the geo-location of the user IP address. The maintainer removed the malicious code in version 10.1.3.
Related
Alias · CVE (1)
- CVE-2022-23812 This affects the package node-ipc from 10.1.1 and before 10.1.3. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-23812 advisory
- https://github.com/RIAEvangelist/node-ipc/issues/233 web
- https://github.com/RIAEvangelist/node-ipc/issues/236 web
- https://github.com/RIAEvangelist/node-ipc/commit/847047cf7f81ab08352038b2204f0e7633449580 web
- https://github.com/RIAEvangelist/node-ipc package
- https://github.com/RIAEvangelist/node-ipc/blob/847047cf7f81ab08352038b2204f0e7633449580/dao/ssl-geospec.js web
- https://security.netapp.com/advisory/ntap-20220407-0005 web
- https://snyk.io/vuln/SNYK-JS-NODEIPC-2426370 web