GitHub Advisoryadvisory · Packagist
GHSA-97qf-pq7x-964m Moodle Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-23921
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-03-02
Affected packages
• Packagist moodle/moodle: < 3.9.19 → fixed in 3.9.19
• Packagist moodle/moodle: >= 3.10.0, < 3.11.12 → fixed in 3.11.12
• Packagist moodle/moodle: >= 4.0.0-beta, < 4.0.6 → fixed in 4.0.6
• Packagist moodle/moodle: >= 4.1.0-beta, < 4.1.1 → fixed in 4.1.1
Description
The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in some returnurl parameters. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website. This flaw allows a remote attacker to perform cross-site scripting (XSS) attacks.
Related
Alias · CVE (1)
- CVE-2023-23921 The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in some returnurl parameters. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness