GitHub Advisoryadvisory · npm
GHSA-97x5-cc53-cv4v Cross site scripting in froala-editor
MEDIUM
Official page ↗
- Aliases
- CVE-2020-22864
- Ecosystem
- npm
- Packages
- froala-editor
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-10-28
Affected packages
• npm froala-editor: < 4.0.11 → fixed in 4.0.11
Description
A cross site scripting (XSS) vulnerability in the Insert Video function of Froala WYSIWYG Editor allows attackers to execute arbitrary web scripts or HTML.
Related
Alias · CVE (1)
- CVE-2020-22864 A cross site scripting (XSS) vulnerability in the Insert Video function of Froala WYSIWYG Editor 3.1.0 allows attackers to execute… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-22864 advisory
- https://github.com/froala/wysiwyg-editor/issues/3880 web
- https://github.com/418sec/wysiwyg-editor/pull/1 web
- https://github.com/froala/wysiwyg-editor/pull/3911 web
- https://github.com/froala/wysiwyg-editor package
- https://github.com/froala/wysiwyg-editor/releases/tag/v4.0.11 web
- https://www.youtube.com/watch?v=WE3b1iSnWJY web