GitHub Advisoryadvisory · Packagist

GHSA-98h9-727m-44qv Drupal core Multiple vulnerabilities due to the use of the third-party library Archive_Tar

HIGH Published 2024-05-15 Modified 2024-05-15 Official page ↗
Ecosystem
Packagist
Packages
drupal/core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Reviewed
2024-05-15

Affected packages

• Packagist drupal/core: >= 7.0.0, < 7.69 → fixed in 7.69 • Packagist drupal/core: >= 8.0.0, < 8.7.11 → fixed in 8.7.11 • Packagist drupal/core: >= 8.8.0, < 8.8.1 → fixed in 8.8.1

Description

The Drupal project uses the third-party library Archive_Tar, which has released a security improvement that is needed to protect some Drupal configurations. Multiple vulnerabilities are possible if Drupal is configured to allow .tar, .tar.gz, .bz2 or .tlz file uploads and processes them. The latest versions of Drupal update Archive_Tar to 1.4.9 to mitigate the file processing vulnerabilities.

References