GitHub Advisoryadvisory · Packagist

GHSA-98j2-3jv7-274m Mautic stored Cross-site Scripting (XSS)

CRITICAL Published 2022-05-24 Modified 2024-04-23 Official page ↗
Aliases
CVE-2020-35128
Ecosystem
Packagist
Packages
mautic/core
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-79
Reviewed
2024-04-23

Affected packages

• Packagist mautic/core: >= 3.2.0, < 3.2.4 → fixed in 3.2.4 • Packagist mautic/core: >= 2.0.0, < 2.16.5 → fixed in 2.16.5

Description

Mautic before 3.2.4 is affected by stored XSS. An attacker with permission to manage companies, an application feature, could attack other users, including administrators. For example, by loading an externally crafted JavaScript file, an attacker could eventually perform actions as the target user. These actions include changing the user passwords, altering user or email addresses, or adding a new administrator to the system.

Related

Alias · CVE (1)

  • CVE-2020-35128 Mautic before 3.2.4 is affected by stored XSS. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References