GitHub Advisoryadvisory · Packagist

GHSA-98j6-67v3-mw34 Auth0 Symfony SDK Deserialization of Untrusted Data vulnerability

CRITICAL Published 2025-06-06 Modified 2025-06-06 Official page ↗
Ecosystem
Packagist
Packages
auth0/symfony
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H
Weaknesses
CWE-502
Reviewed
2025-06-06

Affected packages

• Packagist auth0/symfony: >= 5.0.0-BETA0, < 5.1.0 → fixed in 5.1.0

Description

Overview The Auth0 Symfony SDK contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Am I Affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0 Symfony SDK, versions between 5.0.0 BETA-0 to 5.0.0. 2. Auth0 Symfony SDK uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0. Fix Upgrade Auth0/symfony to the latest version (v5.4.0). Acknowledgement Okta would like to thank Andreas Forsblom for discovering this vulnerability.

Related

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References