GitHub Advisoryadvisory · RubyGems
GHSA-98mf-8f57-64qf actionpack Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2012-3463
- Ecosystem
- RubyGems
- Packages
- actionpack
- Severity
- Moderate
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• RubyGems actionpack: >= 3.0, < 3.0.17 → fixed in 3.0.17
• RubyGems actionpack: >= 3.1.0, < 3.1.8 → fixed in 3.1.8
• RubyGems actionpack: >= 3.2.0, < 3.2.8 → fixed in 3.2.8
Description
Cross-site scripting (XSS) vulnerability in `actionpack/lib/action_view/helpers/form_tag_helper.rb` in Ruby on Rails 3.x before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 allows remote attackers to inject arbitrary web script or HTML via the `prompt` field to the `select_tag` helper.
Related
Alias · CVE (1)
- CVE-2012-3463 Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_tag_helper.rb in Ruby on Rails 3.x before 3.0.17, 3.1.x… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2012-3463 advisory
- https://github.com/rails/rails/commit/6d0526db91afb0675c2ad3d871529d1536303c64 web
- https://groups.google.com/g/rubyonrails-security/c/fV3QUToSMSw/m/eHBSFOUYHpYJ?pli=1 web
- https://groups.google.com/group/rubyonrails-security/msg/961e18e514527078?dmode=source&output=gplain web
- http://rhn.redhat.com/errata/RHSA-2013-0154.html web
- http://weblog.rubyonrails.org/2012/8/9/ann-rails-3-2-8-has-been-released web