GitHub Advisoryadvisory · PyPI

GHSA-98vv-pw6r-q6q4 Uncontrolled Resource Consumption in pillow

HIGH Published 2021-09-07 Modified 2024-10-09 Official page ↗
Aliases
CVE-2021-23437
Ecosystem
PyPI
Packages
pillow
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-125, CWE-400
Reviewed
2021-09-07

Affected packages

• PyPI pillow: >= 5.2.0, < 8.3.2 → fixed in 8.3.2

Description

The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.

Related

Alias · CVE (1)

  • CVE-2021-23437 The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function. vulnerability

Weakness · CWE (2)

  • CWE-125 Out-of-bounds Read weakness
  • CWE-400 Uncontrolled Resource Consumption weakness

References