GitHub Advisoryadvisory · PyPI

GHSA-997v-r4v7-9f3g PyOD persistence.load deserializes untrusted artifacts before validation

MEDIUM Published 2026-07-13 Modified 2026-09-03 Official page ↗
Aliases
CVE-2026-15529
Ecosystem
PyPI
Packages
pyod
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-20, CWE-502
Reviewed
2026-09-03

Affected packages

• PyPI pyod: >= 3.5.0, < 3.6.2 → fixed in 3.6.2

Description

A vulnerability was detected in yzhao062 pyod 3.5.0/3.5.1/3.5.2. Affected is the function pyod.utils.persistence.load of the file pyod/utils/persistence.py. Performing a manipulation of the argument path results in deserialization. The attack can be initiated remotely. The pull request to fix this issue requires some minor changes.

Related

Alias · CVE (1)

  • CVE-2026-15529 A vulnerability was detected in yzhao062 pyod up to 3.6.1. vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-502 Deserialization of Untrusted Data weakness

References