GitHub Advisoryadvisory · Maven
GHSA-99mf-f3qh-wqrp Improper Input Validation in Jenkins Pipeline: Groovy Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2109
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins.workflow:workflow-cps
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-06-24
Affected packages
• Maven org.jenkins-ci.plugins.workflow:workflow-cps: < 2.79 → fixed in 2.79
Description
Sandbox protection in Jenkins Pipeline: Groovy Plugin 2.78 and earlier can be circumvented through default parameter expressions in CPS-transformed methods.
Related
Alias · CVE (1)
- CVE-2020-2109 Sandbox protection in Jenkins Pipeline: Groovy Plugin 2.78 and earlier can be circumvented through default parameter expressions in… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2109 advisory
- https://github.com/jenkinsci/workflow-cps-plugin/commit/41cb4e05eed6a901d0c8a8b0a460111a64c5e179 web
- https://github.com/jenkinsci/workflow-cps-plugin/commit/90b7f403882e1cab1dec49a011e377f440f8e003 web
- https://jenkins.io/security/advisory/2020-02-12/#SECURITY-1710 web
- http://www.openwall.com/lists/oss-security/2020/02/12/3 web