GitHub Advisoryadvisory · PyPI

GHSA-99w6-3xph-cx78 Ansible-Core vulnerable to content protections bypass

LOW Published 2024-11-12 Modified 2026-03-19 Official page ↗
Aliases
CVE-2024-11079
Ecosystem
PyPI
Packages
ansible-core
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L
Weaknesses
CWE-20
Reviewed
2024-11-12

Affected packages

• PyPI ansible-core: >= 2.18.0b1, < 2.18.1rc1 → fixed in 2.18.1rc1 • PyPI ansible-core: >= 2.17.0b1, < 2.17.7rc1 → fixed in 2.17.7rc1 • PyPI ansible-core: < 2.16.14rc1 → fixed in 2.16.14rc1

Description

A flaw was found in Ansible-Core. This vulnerability allows attackers to bypass unsafe content protections using the hostvars object to reference and execute templated content. This issue can lead to arbitrary code execution if remote data or module outputs are improperly templated within playbooks.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References