GitHub Advisoryadvisory · RubyGems

GHSA-9c2j-593q-3g82 activesupport Improper Input Validation vulnerability

MEDIUM Published 2017-10-24 Modified 2023-06-01 Official page ↗
Aliases
CVE-2013-1856
Ecosystem
RubyGems
Packages
activesupport
Severity
Moderate
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• RubyGems activesupport: >= 3.0.0, < 3.1.12 → fixed in 3.1.12 • RubyGems activesupport: >= 3.2.0, < 3.2.13 → fixed in 3.2.13

Description

The `ActiveSupport::XmlMini_JDOM` backend in `lib/active_support/xml_mini/jdom.rb` in the Active Support component in Ruby on Rails 3.0.x and 3.1.x before 3.1.12 and 3.2.x before 3.2.13, when JRuby is used, does not properly restrict the capabilities of the XML parser, which allows remote attackers to read arbitrary files or cause a denial of service (resource consumption) via vectors involving (1) an external DTD or (2) an external entity declaration in conjunction with an entity reference.

Related

Alias · CVE (1)

  • CVE-2013-1856 The ActiveSupport::XmlMini_JDOM backend in lib/active_support/xml_mini/jdom.rb in the Active Support component in Ruby on Rails 3.0.x and… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References