GitHub Advisoryadvisory · Maven
GHSA-9cfq-v2hm-c3xr Jenkins GitHub Branch Source Plugin vulnerable to Server-Side Request Forgery
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000185
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:github-branch-source
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-918
- Reviewed
- 2022-12-12
Affected packages
• Maven org.jenkins-ci.plugins:github-branch-source: < 2.3.5 → fixed in 2.3.5
Description
A server-side request forgery vulnerability exists in Jenkins GitHub Branch Source Plugin 2.3.4 and older in Endpoint.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL. Additionally, this form validation method did not require POST requests, resulting in a CSRF vulnerability. As of version 23.5, this form validation method requires POST requests and the Overall/Administer permission.
Related
Alias · CVE (1)
- CVE-2018-1000185 A server-side request forgery vulnerability exists in Jenkins GitHub Branch Source Plugin 2.3.4 and older in Endpoint.java that allows… vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness