GitHub Advisoryadvisory · Maven

GHSA-9cmq-m9j5-mvww Spring Framework vulnerable to Denial of Service

MEDIUM Published 2024-08-20 Modified 2025-06-18 Official page ↗
Aliases
CVE-2024-38808
Ecosystem
Maven
Packages
org.springframework:spring-expression
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Weaknesses
CWE-770
Reviewed
2024-08-20

Affected packages

• Maven org.springframework:spring-expression: < 5.3.39 → fixed in 5.3.39

Description

In Spring Framework versions 5.3.0 - 5.3.38 and older unsupported versions, it is possible for a user to provide a specially crafted Spring Expression Language (SpEL) expression that may cause a denial of service (DoS) condition. Older, unsupported versions are also affected. Specifically, an application is vulnerable when the following is true: • The application evaluates user-supplied SpEL expressions.

Related

Alias · CVE (1)

  • CVE-2024-38808 In Spring Framework versions 5.3.0 - 5.3.38 and older unsupported versions, it is possible for a user to provide a specially crafted Spring… vulnerability

Weakness · CWE (1)

  • CWE-770 Allocation of Resources Without Limits or Throttling weakness

References