GitHub Advisoryadvisory · Packagist

GHSA-9cq2-pcgr-8h62 Cross-site Scripting in eZFind spellcheck

HIGH Published 2024-05-15 Modified 2024-05-15 Official page ↗
Ecosystem
Packagist
Packages
ezsystems/ezfind-ls
Severity
High
Weaknesses
CWE-79
Reviewed
2024-05-15

Affected packages

• Packagist ezsystems/ezfind-ls: >= 2017.12.0, < 2017.12.0.1 → fixed in 2017.12.0.1 • Packagist ezsystems/ezfind-ls: >= 5.4.0, < 5.4.11.1 → fixed in 5.4.11.1 • Packagist ezsystems/ezfind-ls: >= 5.3.0, < 5.3.6.1 → fixed in 5.3.6.1

Description

This security advisory fixes a vulnerability in the legacy eZ Find extension, which can be used with the LegacyBridge in eZ Platform. It affects sites using the "Did you mean...?" spell check / search suggestion feature. This feature is vulnerable to Cross-site Scripting (XSS) injection (reflected XSS). The update adds the necessary escaping of injected code. If you're affected, we recommend that you install it as soon as possible. If you have custom search templates, please make sure you update these as well. Ensure that "search_extras.spellcheck_collation" is followed by the "wash" operator, like this: {$search_extras.spellcheck_collation|wash} To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezfind/commit/51c17ea9b1231c20db8221f34d01c649060f1e91

Related

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References